Serious misfire on Tiger.

Post any Tech Tips or any matters and questions relating to upkeep
Post Reply
Shindles
Posts: 48
Joined: Tue Jun 28, 2016 5:23 pm

Serious misfire on Tiger.

Post by Shindles » Sun Apr 30, 2017 12:12 pm

I have a serious misfire and the car conks out when driving.
I've changed the coil, condenser, fuel pump, fuel filter and checked the points gap.
What else could it possible be - help!

stuartb

Post by stuartb » Sun Apr 30, 2017 12:46 pm

Have you tried another Rotor arm, They often break down when they get warm.

Shindles
Posts: 48
Joined: Tue Jun 28, 2016 5:23 pm

Misfire

Post by Shindles » Sun Apr 30, 2017 1:40 pm

Thanks I'll try that.

Mal
Posts: 669
Joined: Sat Aug 02, 2008 5:39 am
Location: NZ

Post by Mal » Mon May 01, 2017 7:36 pm

Check for a crack in the distributor cap.
Image

Shindles
Posts: 48
Joined: Tue Jun 28, 2016 5:23 pm

Still misfiring

Post by Shindles » Tue May 09, 2017 10:33 am

OK bought a new distributor cap, rotor arm, points, condenser, coil and plug leads. Problem persists.
Conclusion it must be fuel. New SU fuel pump fitted, will now buy a fuel pressure meter so what should the pressure be?

meadowhog
Posts: 392
Joined: Fri Dec 16, 2011 1:50 pm
Location: South Bucks

Post by meadowhog » Thu May 11, 2017 10:30 pm

7psi max

Shindles
Posts: 48
Joined: Tue Jun 28, 2016 5:23 pm

Still misfiring

Post by Shindles » Tue May 16, 2017 4:23 pm

Pressure tested OK, dismantled carburettor and it's clean as a whistle.
So what next to check?
Could it be a coincidence that the serious misfire (so bad it's undriveable) only started after fitting a Kenlowe fan? If so, why does the misfire occur regardless of the engine temperature?
Could there be a problem with the ignition switch?

nicam
Posts: 19
Joined: Tue Aug 06, 2013 11:37 am

Post by nicam » Thu May 18, 2017 12:59 pm

How about running it with a strobe timing light fitted to the distributor king lead and then to each of the plug leads in turn - watching the flashes will at least tell you if it is a spark failure causing the misfire.

Shindles
Posts: 48
Joined: Tue Jun 28, 2016 5:23 pm

Post by Shindles » Thu May 18, 2017 3:23 pm

Problem is that when the car won't start there is still a spark from the king lead. If it was a single spark plug problem the car would start but be very rough.

Shindles
Posts: 48
Joined: Tue Jun 28, 2016 5:23 pm

Solved

Post by Shindles » Wed May 31, 2017 3:20 pm

I broke the number one rule when trying to cure a problem - do not replace several components at once.
It turned out that the new condenser was faulty!
Thanks for everyone's help tackling this, at least I now have new points, distributor, ballast resistor, coil fuel pump and rotor arm!

Post Reply