Windscreen wipers blowing fuses

Post any Tech Tips or any matters and questions relating to upkeep
Post Reply
meadowhog
Posts: 391
Joined: Fri Dec 16, 2011 1:50 pm
Location: South Bucks

Windscreen wipers blowing fuses

Post by meadowhog » Tue Jun 02, 2015 10:14 pm

My windscreen wipers have packed up and I'm looking for a cause. I have replaced outer winding and body with a spare. Not sure if it's burnt out but I have continuity.
I've turned the motor so the wipers have started to move in the hope of seeing if there is change as the self park as it would be wanting to move them back. They moved freely. I've not found that this has made any difference as it still blows fuses. I've even taken both earth wires off, one on the housing and one on the switch and it still blows. It must be shorting in the motor somewhere as when the green +12v supply is pulled the brake lights work normally. They run from the same fuse.
I just can't for the life of me think where it can be, there's no obviously burn marks, I'm stumped.

meadowhog
Posts: 391
Joined: Fri Dec 16, 2011 1:50 pm
Location: South Bucks

Post by meadowhog » Fri Jun 12, 2015 6:30 pm

Well, I stripped it out and cleaned off old greace. There was no continuity apart from earthe wires so a bit stumped as to why I blew fuses with them disconnected. Tested the motor at all points of rebuild, which worked fine. Refitted and it works.

meadowhog
Posts: 391
Joined: Fri Dec 16, 2011 1:50 pm
Location: South Bucks

Post by meadowhog » Tue Jun 16, 2015 10:14 pm

Thought I'd post a link which I found very helpful.

http://www.britishcarforum.com/bcf/cont ... per-motors

There are others which seem to be more easily found and with pictures but don't really explain how our 2 speed motors work.

Post Reply